6. Implementing OSPF over NBMA
6.1 Understanding OSPF Network Types
6.1.1 Broadcast, Multi-Access Networks
6.1.2 Point-to-point Networks
6.1.3 Non-Broadcast Multi-Access (NBMA) Networks
6.2 NBMA Topologies
6.3 OSPF over NBMA: Five Modes
6.3.1 Non-Broadcast Mode (.1)
6.3.2 Point-to-Multipoint Mode (.2)
6.3.3 Point-to-Point – Cisco Proprietary (.3)
6.3.4 Point-to-Mulitpoint, Non-Broadcast – Cisco Proprietary (.5)
• Neighbors automatically form
6.4 Implementing OSPF over Multiple Network Types
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
FRS2
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 204 interface Serial1/3 402
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 402 interface Serial1/2 204
FRS3
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 305 interface Serial1/4 503
frame-relay route 306 interface Serial1/5 603
interface Serial1/4
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 503 interface Serial1/3 305
interface Serial1/5
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 603 interface Serial1/3 306
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/0.1 multipoint
ip address 10.12.3.1 255.255.255.0
frame-relay map ip 10.12.3.2 102 broadcast
frame-relay map ip 10.12.3.3 103 broadcast
R1#sh ip int brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial1/0 unassigned YES NVRAM up up
Serial1/0.1 10.12.3.1 YES NVRAM up up
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM administratively down down
Serial1/3 unassigned YES NVRAM administratively down down
Serial1/4 unassigned YES NVRAM administratively down down
Serial1/5 unassigned YES NVRAM administratively down down
Serial1/6 unassigned YES NVRAM administratively down down
Serial1/7 unassigned YES NVRAM administratively down down
Loopback0 1.1.1.1 YES NVRAM up up
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.12.3.0 0.0.0.255 area 0
neighbor 10.12.3.2
neighbor 10.12.3.3
R1#sh ip os int
Loopback0 is up, line protocol is up
Internet Address 1.1.1.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial1/0.1 is up, line protocol is up
Internet Address 10.12.3.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, Interface address 10.12.3.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:23
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 2.2.2.2
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)
++++++++++++++ R2# +++++++++++++++
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/1.1 multipoint
ip address 10.12.3.2 255.255.255.0
ip ospf priority 0
frame-relay map ip 10.12.3.3 201 broadcast
frame-relay map ip 10.12.3.1 201 broadcast
interface Serial1/2.1 point-to-point
ip address 10.24.0.2 255.255.255.0
frame-relay interface-dlci 204
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.12.3.0 0.0.0.255 area 0
network 10.24.0.2 0.0.0.0 area 24
R2#sh ip int brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial1/0 unassigned YES NVRAM administratively down down
Serial1/1 unassigned YES NVRAM up up
Serial1/1.1 10.12.3.2 YES NVRAM up up
Serial1/2 unassigned YES NVRAM up up
Serial1/2.1 10.24.0.2 YES NVRAM up up
Serial1/3 unassigned YES NVRAM administratively down down
Serial1/4 unassigned YES NVRAM administratively down down
Serial1/5 unassigned YES NVRAM administratively down down
Serial1/6 unassigned YES NVRAM administratively down down
Serial1/7 unassigned YES NVRAM administratively down down
Loopback0 2.2.2.2 YES NVRAM up up
R2#sh ip os int
Loopback0 is up, line protocol is up
Internet Address 2.2.2.2/24, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial1/1.1 is up, line protocol is up
Internet Address 10.12.3.2/24, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 1.1.1.1, Interface address 10.12.3.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1 (Designated Router)
Suppress hello for 0 neighbor(s)
Serial1/2.1 is up, line protocol is up
Internet Address 10.24.0.2/24, Area 24
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 4, maximum is 4
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 4.4.4.4
Suppress hello for 0 neighbor(s)
++++++++++++++ R3# +++++++++++++++
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/2.1 multipoint
ip address 10.12.3.3 255.255.255.0
ip ospf priority 0
frame-relay map ip 10.12.3.2 301 broadcast
frame-relay map ip 10.12.3.1 301 broadcast
interface Serial1/3.1 multipoint
ip address 10.35.6.3 255.255.255.0
ip ospf network point-to-multipoint
ip ospf hello-interval 10
frame-relay map ip 10.35.6.6 306 broadcast
frame-relay map ip 10.35.6.5 305 broadcast
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.12.3.0 0.0.0.255 area 0
network 10.35.6.3 0.0.0.0 area 356
R3#sh ip int brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial1/0 unassigned YES NVRAM administratively down down
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM up up
Serial1/2.1 10.12.3.3 YES NVRAM up up
Serial1/3 unassigned YES NVRAM up up
Serial1/3.1 10.35.6.3 YES NVRAM up up
Serial1/4 unassigned YES NVRAM administratively down down
Serial1/5 unassigned YES NVRAM administratively down down
Serial1/6 unassigned YES NVRAM administratively down down
Serial1/7 unassigned YES NVRAM administratively down down
Loopback0 3.3.3.3 YES NVRAM up up
R3# sh ip os int
Loopback0 is up, line protocol is up
Internet Address 3.3.3.3/24, Area 0
Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial1/2.1 is up, line protocol is up
Internet Address 10.12.3.3/24, Area 0
Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 1.1.1.1, Interface address 10.12.3.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1 (Designated Router)
Suppress hello for 0 neighbor(s)
Serial1/3.1 is up, line protocol is up
Internet Address 10.35.6.3/24, Area 356
Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 5
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 6.6.6.6
Adjacent with neighbor 5.5.5.5
Suppress hello for 0 neighbor(s)
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/3.1 point-to-point
ip address 10.24.0.4 255.255.255.0
frame-relay interface-dlci 402
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 24
network 10.24.0.0 0.0.0.255 area 24
R4#sh ip int brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial1/0 unassigned YES NVRAM administratively down down
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM administratively down down
Serial1/3 unassigned YES NVRAM up up
Serial1/3.1 10.24.0.4 YES manual up up
Serial1/4 unassigned YES NVRAM administratively down down
Serial1/5 unassigned YES NVRAM administratively down down
Serial1/6 unassigned YES NVRAM administratively down down
Serial1/7 unassigned YES NVRAM administratively down down
Loopback0 4.4.4.4 YES manual up up
R4# sh ip os int
Loopback0 is up, line protocol is up
Internet Address 4.4.4.4/24, Area 24
Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial1/3.1 is up, line protocol is up
Internet Address 10.24.0.4/24, Area 24
Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
interface Loopback0
ip address 5.5.5.5 255.255.255.0
ip ospf network point-to-point
interface Serial1/4
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/4.1 point-to-point
ip address 10.35.6.5 255.255.255.0
frame-relay interface-dlci 503
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 356
network 10.35.6.0 0.0.0.255 area 356
R5#sh ip int brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial1/0 unassigned YES NVRAM administratively down down
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM administratively down down
Serial1/3 unassigned YES NVRAM up down
Serial1/3.1 unassigned YES manual deleted down
Serial1/4 unassigned YES NVRAM up up
Serial1/4.1 10.35.6.5 YES manual up up
Serial1/5 unassigned YES NVRAM administratively down down
Serial1/6 unassigned YES NVRAM administratively down down
Serial1/7 unassigned YES NVRAM administratively down down
Loopback0 5.5.5.5 YES manual up up
R5# sh ip os int
Loopback0 is up, line protocol is up
Internet Address 5.5.5.5/24, Area 356
Process ID 1, Router ID 5.5.5.5, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial1/4.1 is up, line protocol is up
Internet Address 10.35.6.5/24, Area 356
Process ID 1, Router ID 5.5.5.5, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)
++++++++++++++ R6# +++++++++++++++
interface Loopback0
ip address 6.6.6.6 255.255.255.0
ip ospf network point-to-point
interface Serial1/5
no ip address
encapsulation frame-relay
serial restart-delay 0
interface Serial1/5.1 point-to-point
ip address 10.35.6.6 255.255.255.0
frame-relay interface-dlci 603
router ospf 1
router-id 6.6.6.6
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 356
network 10.35.6.0 0.0.0.255 area 356
R6#sh ip int brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial1/0 unassigned YES NVRAM administratively down down
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM administratively down down
Serial1/3 unassigned YES NVRAM administratively down down
Serial1/4 unassigned YES NVRAM administratively down down
Serial1/5 unassigned YES NVRAM up up
Serial1/5.1 10.35.6.6 YES manual up up
Serial1/6 unassigned YES NVRAM administratively down down
Serial1/7 unassigned YES NVRAM administratively down down
Loopback0 6.6.6.6 YES manual up up
R6#sh ip os int
Loopback0 is up, line protocol is up
Internet Address 6.6.6.6/24, Area 356
Process ID 1, Router ID 6.6.6.6, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial1/5.1 is up, line protocol is up
Internet Address 10.35.6.6/24, Area 356
Process ID 1, Router ID 6.6.6.6, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)