cisco hands-on experience


Implementing Basic EIGRP


2 Basic Configuration
  • 2.1 Configuration basics
  • 2.2 Advertising default information into EIGRP
  • 2.3 Passive interfaces
  • 2.4 Summarization options


2.1 Configuration basics

figure 1

      Objectives

      • Configure EIGRP for the shown network using EIGRP AS 90. Corporate policy dictates you must
      use specific wildcard mask on R2 and R3. In addition, EIGRP should be configured in such a way that
      it does not operate like a classful routing protocol. Finally, the BB router has a static route to
      192.168.1.0/24; R2 and R3 should receive this route via EIGRP without using redistribution

      configuration for BB
      interface Loopback0
      ip address 172.30.0.1 255.255.255.0
      !
      interface Loopback1
      ip address 172.30.1.1 255.255.255.0
      !
      interface Loopback2
      ip address 172.30.2.1 255.255.255.0
      !
      interface Loopback3
      ip address 172.30.3.1 255.255.255.0
      !
      interface Loopback4
      ip address 172.30.4.1 255.255.255.0
      !
      interface Loopback5
      ip address 172.30.5.1 255.255.255.0
      !
      interface Loopback6
      ip address 172.30.6.1 255.255.255.0
      !
      interface Loopback7
      ip address 172.30.7.1 255.255.255.0
      !
      interface Loopback8
      ip address 172.30.8.1 255.255.255.0
      !
      .
      .
      !
      interface Serial2/0
      bandwidth 128
      ip address 10.1.24.1 255.255.255.252
      serial restart-delay 0
      !
      interface Serial2/1
      bandwidth 256
      ip address 10.1.34.1 255.255.255.252
      serial restart-delay 0
      !
      .
      .

      router eigrp 90
      network 10.1.0.0 0.0.255.255
      network 172.30.0.0
      no auto-summary
      .
      .
      ip route 192.168.1.0 255.255.255.0 Null0

      configuration for R2#
      !
      interface FastEthernet0/0
      ip address 10.1.2.2 255.255.255.0
      duplex auto
      speed auto
      !
      interface FastEthernet0/1
      ip address 10.1.25.2 255.255.255.0
      duplex auto
      speed auto
      !
      interface Serial2/0
      bandwidth 128
      ip address 10.1.24.2 255.255.255.252
      serial restart-delay 0
      !
      .
      .
      router eigrp 90
      network 10.1.2.2 0.0.0.0
      network 10.1.24.2 0.0.0.0
      network 10.1.25.2 0.0.0.0
      no auto-summary

      configuration for R3#
      !
      interface FastEthernet0/0
      ip address 10.1.2.3 255.255.255.0
      duplex auto
      speed auto
      !
      .
      .
      !
      interface Serial2/1
      bandwidth 256
      ip address 10.1.34.2 255.255.255.252
      serial restart-delay 0
      !
      .
      .
      !
      router eigrp 90
      network 10.1.2.3 0.0.0.0
      network 10.1.34.2 0.0.0.0
      no auto-summary
      !


      redistribute static

      BB(config-router)#redistribute static
      On R2# with the show command you see an EIGRP external route
      D EX 192.168.1.0/24 [170/10514432] via 10.1.2.3, 00:00:41, FastEthernet0/0

      BB(config-router)#network 192.168.1.0
      You can also choose the network comman in the EIGRP process to insert the static route. It’s very simple and you get following output on R2#
      D 192.168.1.0/24 [90/10514432] via 10.1.2.3, 00:02:13, FastEthernet0/0


      • R2 and R3 should have a default route pointing to the 192.168.1.0/24 network at the corporate
      office. No static routes can be used to accomplish this.

      * – candidate default
      BB#conf t
      BB(config)#ip default-network 192.168.1.0
      .
      .
      BB(config)#do show ip route
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      Gateway of last resort is not set

      172.30.0.0/24 is subnetted, 9 subnets
      C 172.30.2.0 is directly connected, Loopback2
      C 172.30.3.0 is directly connected, Loopback3
      C 172.30.0.0 is directly connected, Loopback0
      C 172.30.1.0 is directly connected, Loopback1
      C 172.30.6.0 is directly connected, Loopback6
      C 172.30.7.0 is directly connected, Loopback7
      C 172.30.4.0 is directly connected, Loopback4
      C 172.30.5.0 is directly connected, Loopback5
      C 172.30.8.0 is directly connected, Loopback8
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      D 10.1.2.0/24 [90/10514432] via 10.1.34.2, 00:02:40, Serial2/1
      D 10.1.25.0/24 [90/10516992] via 10.1.34.2, 00:02:40, Serial2/1
      C 10.1.24.0/30 is directly connected, Serial2/0
      C 10.1.34.0/30 is directly connected, Serial2/1
      S* 192.168.1.0/24 is directly connected, Null0
      .
      .
      R2#show ip route
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      Gateway of last resort is 10.1.2.3 to network 192.168.1.0

      172.30.0.0/24 is subnetted, 9 subnets
      D 172.30.2.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.3.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.0.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.1.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.6.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.7.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.4.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.5.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D 172.30.8.0 [90/10642432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      C 10.1.2.0/24 is directly connected, FastEthernet0/0
      C 10.1.25.0/24 is directly connected, FastEthernet0/1
      C 10.1.24.0/30 is directly connected, Serial2/0
      D 10.1.34.0/30 [90/10514432] via 10.1.2.3, 00:34:58, FastEthernet0/0
      D* 192.168.1.0/24 [90/10514432] via 10.1.2.3, 00:03:22, FastEthernet0/0

      the network command has to be classful
      It is a valid method to send a default route in EIGRP

      • In order to meet security standards, EIGRP should not form neighbor relationships on any interface
      where other EIGRP routers do not exist.

      we need a passive interface
      R2#sh ip int brie
      Interface IP-Address OK? Method Status Protocol
      FastEthernet0/0 10.1.2.2 YES NVRAM up up
      FastEthernet0/1 10.1.25.2 YES NVRAM up up
      FastEthernet1/0 unassigned YES NVRAM administratively down down
      FastEthernet1/1 unassigned YES NVRAM administratively down down
      Serial2/0 10.1.24.2 YES NVRAM up up
      Serial2/1 unassigned YES NVRAM administratively down down
      Serial2/2 unassigned YES NVRAM administratively down down

      R2#conf t
      R2(config)#router eig 90
      R2(config-router)#pass
      R2(config-router)#passive-interface fa0/1
      R2(config-router)#

      in EIGRP no hellos were send on dedicated interfaces, but for example RIP advertisements can be received.

      Same thing on Router BB#

      BB#sh run | s eigr
      router eigrp 90
      passive-interface default
      no passive-interface Serial2/0
      no passive-interface Serial2/1
      network 10.1.0.0 0.0.255.255
      network 172.30.0.0
      network 192.168.1.0
      no auto-summary

      BB#



      • To improve the efficiency of the remote routers R2 and R3, the corporate BB router should
      summarize 172.30.0.0 – 172.30.7.255 into a single network advertisement.

      on BB# we need interface s2/0 and s2/1 to do so
      BB(config)#int s2/0
      BB(config-if)#ip summary-address eigrp 90 172.30.0.0 255.255.248.0
      .
      .
      R2#sh ip route
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      Gateway of last resort is 10.1.2.3 to network 192.168.1.0

      172.30.0.0/16 is variably subnetted, 10 subnets, 2 masks
      D 172.30.2.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.3.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.0.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.0.0/21 [90/20640000] via 10.1.24.1, 00:02:10, Serial2/0
      D 172.30.1.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.6.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.7.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.4.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.5.0/24 [90/10642432] via 10.1.2.3, 00:02:11, FastEthernet0/0
      D 172.30.8.0/24 [90/10642432] via 10.1.2.3, 00:10:30, FastEthernet0/0
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      C 10.1.2.0/24 is directly connected, FastEthernet0/0
      C 10.1.25.0/24 is directly connected, FastEthernet0/1
      C 10.1.24.0/30 is directly connected, Serial2/0
      D 10.1.34.0/30 [90/10514432] via 10.1.2.3, 00:10:32, FastEthernet0/0
      D* 192.168.1.0/24 [90/10514432] via 10.1.2.3, 00:10:30, FastEthernet0/0
      R2#
      BB(config-if)#

      nothing happens because successor point to router R3#. We need both serial interfaces to do this summarization.

      BB(config-if)#int s2/1
      BB(config-if)#ip summary-address eigrp 90 172.30.0.0 255.255.248.0
      BB(config-if)#
      *Aug 16 09:39:26.815: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 90: Neighbor 10.1.34.2 (Serial2/1) is resync: summary configured
      .
      .
      R2#sh ip route
      .
      .
      172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
      D 172.30.0.0/21 [90/10642432] via 10.1.2.3, 00:00:07, FastEthernet0/0
      D 172.30.8.0/24 [90/10642432] via 10.1.2.3, 00:13:05, FastEthernet0/0
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      C 10.1.2.0/24 is directly connected, FastEthernet0/0
      C 10.1.25.0/24 is directly connected, FastEthernet0/1
      C 10.1.24.0/30 is directly connected, Serial2/0
      D 10.1.34.0/30 [90/10514432] via 10.1.2.3, 00:13:08, FastEthernet0/0
      D* 192.168.1.0/24 [90/10514432] via 10.1.2.3, 00:13:05, FastEthernet0/0
      R2#
      BB(config-if)#



      • To best utilize available network bandwidth, the corporate BB router should perform unequal load
      balancing to reach the 10.1.2.0/24 network.

      unequal loadbalance
      BB#sh ip eigrp topology
      IP-EIGRP Topology Table for AS(90)/ID(172.30.8.1)

      Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
      r – reply Status, s – sia Status

      P 10.1.2.0/24, 1 successors, FD is 10514432
      via 10.1.34.2 (10514432/28160), Serial2/1
      via 10.1.24.2 (20514560/28160), Serial2/0
      P 10.1.25.0/24, 1 successors, FD is 10516992
      via 10.1.34.2 (10516992/30720), Serial2/1
      via 10.1.24.2 (20514560/28160), Serial2/0


      The successor has a Feasible distance of 10514432
      The feasible successor has a feasible distance of 20514560
      calculate = 10514432 * 2 = 21028864
      The feasible successor is lower than the successor is two times. So it is a valid load balance value.


      The show ip route command shows only one route to the network 10.1.2.0/24

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      D 10.1.2.0/24 [90/10514432] via 10.1.34.2, 00:00:08, Serial2/1
      D 10.1.25.0/24 [90/10516992] via 10.1.34.2, 00:00:08, Serial2/1

      BB#conf t
      BB(config)#router eigrp 90
      BB(config-router)#va
      BB(config-router)#variance ?
      <1-128> Metric variance multiplier
      BB(config-router)#variance 2
      BB(config-router)#end
      BB#

      After the variance command the output show 2 valid routes
      .
      .
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      D 10.1.2.0/24 [90/10514432] via 10.1.34.2, 00:00:03, Serial2/1
      [90/20514560] via 10.1.24.2, 00:00:03, Serial2/0